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Atomic Force Microscopy

Abstract:

The Atomic Force Microscope is a versatile, high resolution microscope for
imaging conducting and non conducting materials with nanometer
resolution. In this lab course, you will learn the basic principles of AFM,
learn how to operate an AFM and how to perform AFM specific image

processing.

Specific learning objectives:

After this lab module you will know how to:

* perform imaging of biological samples using a state-of-the-art AFM
system

* recognize and remove artifacts in the AFM images (a lot of AFM
images in the research papers are poorly processed!)

* process and display obtained AFM image to present measured data in
the best way

* extract quantitative information about the sample from the AFM
images
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1 1. THEORY
1.1 History: from STM to AFM

The atomic force microscope (AFM) was developed in 1986, by Gerd Binning, Calvin Quate
and Christoph Gerber' in an attempt to image non-conducting samples with atomic resolution.
Four years earlier, Binning, Gerber, Rohrer and Wiebel had invented the scanning tunneling
microscope (STM) that had already succeeded in imaging conducting samples with atomic
resolution. This was done by applying a potential difference (Vi) between the conducting
sample surface and an atomically flat tip, while measuring the quantum mechanical tunneling
current between the tip and the sample. If |V{| is small compared to the workfunction @ , the
tunneling current is given by:

1(2) = I,e™>
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where z is the gap Iy is a function of the applied voltage, the density of states in the tip and the
sample, and x, =2m®/h. Because of the exponential dependency of I; on the distance z,
tunneling is a very sensitive method to detect the surface topography. For the same reason, the
most current is carried by “front atom” of the tip, so atomic resolution is possible even with
relatively blunt tips. The tip is then raster scanned relative to the surface of the sample and the
tunneling current is recorded for each point, which than can be plotted as a 2D-image. Since
the tunneling current falls off so rapidly with distance, STMs are generally operated in a closed
loop, where the tip-sample distance is held constant using a feedback loop that moves the tip in
the out of plane (z) direction. This allows the imaging of samples higher than the decay length
of the tunneling probability.

The approach that Binnig, Quate and Gerber used to also image non conducting samples, was
to add a conductive “mediator” between the sample and the STM tip in the form of a
cantilever. The cantilever was a very thin gold foil with a shard of diamond glued to the back.
The thin foil acts as a spring that can push the diamond tip onto the sample surface (see the
figure from the original publication in Figure 1). On top of the aluminum foil, the STM is
mounted, which is now used to measure the displacements of the cantilever as it is scanned
over the surface. Figure 1C shows the first AFM image traces ever recorded.
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Figure 1: figures from first AFM paper

1.1 Current AFM technology and Instrumentation

AFMs are now widely used in many areas such as materials science, nanotechnology,
biophysics, and industrial process control. Modern AFMs are very versatile instruments that
can be used to image nanoparticles, single molecules, semiconductor devices and even living
cells. Since the first AFM prototypes, the technique has changed significantly and many
improvements have made the AFM such a broadly used tool. Two of the main improvements
were the development of microfabriacted cantilevers and the development of the optical lever
detection, which has replaced the STM as the cantilever deflection readout technique.

4
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1.1.1 AFM cantilevers as sensitive displacement and force sensors

In order to record high-resolution AFM images even on soft (biological-) samples, it is
essential to have cantilevers with a sharp tip, high displacement sensitivity and high force
sensitivity. These days AFM cantilevers are fabricated using MEMS fabrication techniques,
most often out of silicon or silicon nitride. Figure 2 shows some example of commercial AFM
cantilevers. Many different varieties are available to suite the specific applications such as
imaging of hard samples in air, or imaging soft samples in aqueous solution.

In order to use the cantilever as a sensor, we need the
relationship between a force (F) acting on the
cantilever, and it’s displacement at the tip (Az). From
elementary beam theory we know that:

Az=w(L)=F-L*/(3-E-I)

Where w(x) is the z displacement of the neutral axis as
a function of the position along the cantilever, L is the
cantilever length, E is the elastic module and I is the
moment of inertia (I=b-h*/12).

For the deflection angle (theta) of the end of the
cantilever we can calculate:

0=dw(L)/dx=F-L*2-E-I)

Figure 2: Commercially available cantilevers

It is important to note, that both the deflection of the
end, as well as the slope at the end of the cantilever is proportional to the force applied to the
tip. We can therefore assign the cantilever a spring constant k given as:

k=3-E-I/L’

1.1.2 Optical lever detection method

While the detection of the cantilever deflection with an STM is a very high resolution method,
it is quite cumbersome and impractical in many applications, especially when imaging
biological samples in fluid. Therefore, most AFMs these days use a laser to detect the
cantilever deflection. This is done by shining a laser onto the back of the reflecting cantilever

and measure the angle of the reflected laser beam using a four-quadrant laser diode (see Figure
3).
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Figure 3: Optical lever deflection method for the detection of the cantilever bending

When the cantilever is deflected, the reflected laser beam hits the four-quadrant photo diode at
a different position. From the total amount of light that hits on the four quadrants, the
deflection as well as the torsion of the cantilever can be measured.

Vertical deflection=(A;+A;)-(B1+B>)
Horizontal deflection (torsion) = (A;+B)-(Ax+B,)

Strictly speaking, we are not measuring the cantilever deflection in z-direction, but rather the
angle of the neutral axis of the deflected cantilever. But since both the angle as well as the
cantilever deflection are proportional to the force (which is proportional to the displacement),
we can use the angle change as a measure for the cantilever deflection.

1.1.3 Feedback mode operation

Feedback control is used in AFM for maintaining a fixed relationship, or force, between the
probe and the surface. The feedback control operates by measuring the force between the
surface and probe, then controlling a piezoelectric ceramic that establishes the relative position
of the probe and surface thereby keeping forces between them at a user-specified setpoint
level. Let us use contact mode as an example. When the control signal (in this case the
cantilever deflection) is above the setpoint, the feedback loop will try to reduce the force
between the cantilever and the sample by contracting the Z-piezo thereby moving the tip a little
further away from the surface. When the deflection is less than the specified setpoint, the
feedback loop will expand the piezo to move the tip closer to the sample.

Although signal processing varies according to the image mode used (contact mode, tapping
mode, etc), the feedback loop always performs essentially the same function.

The feedback system used to control tip-sample interactions and render images must be
optimized for each new sample. This is accomplished by adjusting various gains in the SPM’s
feedback circuit. This section discusses gains and how they are used to obtain images.



ADVANCED BIOENGINEERING METHODS LABORATORY )
Atomic Force Microscopy

. ECOLE POLYTECHNIQUE
Georg Fantner FEDERALE DE LAUSANNE

Signal 2

Processi Non-feedback signals
rocessing (e.g. Amplitude, etc...)

Tip Bias

Error signal

Feedback
Calculation

Figure 4: Schematic depiction of AFM feedback loop

In the AFM, the feedback control electronics take an input from the force sensor and compare
the signal to a set-point value; the error signal is then sent through a feedback controller. The
output of the feedback controller then drives the Z piezoelectric ceramic. The most common
form of feedback control for AFM is the PID controller (Proportional, Integral and
Derivative controller). The proportional, integral, derivative controller takes the error signal
and processes it as follows:

7, = PxZo+Ix| 2. dt + p x e

where Z v is the output signal of the controller that goes to the high voltage amplifier for the z-
piezo, E err is the error signal, and P,I, and D are the gain settings. By selecting the
appropriate P, I and D gain setting, the probe will “track” the surface as it is scanned. The
integral term facilitates the probe moving over large surface features and the P and D terms
allow the probe to follow the smaller, high frequency features on a surface. When the PID
parameters are optimized, the error signal image will be minimal. As a rule of thumb: the
higher the feedback gains, the faster the feedback loop can react to changes in topography
while scanning. Therefore, in an ideal world, one would set the gains as high as possible.
However, since the AFM is not infinitely fast in responding to the output of the PID controller,
one can only increase the feedback gains to a certain point. This also limits the maximum
achievable scan speed. Establishing where this point is requires practice and some intuition. In
the exercise you will learn a simple method to get close to these optimal gain settings.
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Figure S: Top: If the PID parameters are all zero, the cantilever will bend as it moves across the surface features.
Bottom: If the PID parameters are optimized, the cantilever deflection remains constant while scanning.

1.2 AFM Modes

A force sensor in an AFM can only work if the probe interacts with the force field associated with
a surface. In ambient air, the potential energy between the probe and surface is shown in Figure
6. There are three basic regions of interaction between the probe and surface:

« free space
e attractive region
« repulsive region

Repulsive

/ Cantilever pushed up

Figure 6: Potential energy diagram of a probe and sample. The attractive potential is caused by the capillary forces
from surface contamination.

Distance

Attractive

Cantilever pulled down

Attractive forces near the surface are caused by a nanoscopic layer of contamination that is
present on all surfaces in ambient air. The contamination is typically an aerosol composed of
water vapor and hydrocarbons. The amount of contamination depends on the environment in
which the microscope is being operated. Repulsive forces increase as the probe begins to
“contact” the surface. The repulsive forces in the AFM tend to cause the cantilever to bend up.

There are two primary methods for establishing the forces between a probe and a sample when
an AFM is operated. In contact mode the deflection of the cantilever is measured, and in vibrating
mode the changes in frequency and/or amplitude are used to measure the force interaction. As a
rule of thumb, the forces between the probe and surface are greater with contact modes than with
vibrating modes.
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1.2.1 Contact mode

In contact mode, the cantilever is scanned over a surface at a fixed deflection, Figure 7. Provided
that the PID feedback loop is optimized, a constant force is applied to the surface while scanning.
If the PID feedback parameters are not optimized, a variable force is exerted on the surface by a
probe during a scan.

‘ W
-

oint

Distance

Figure 7: Left: Potential diagram showing the region of the probe while scanning in contact mode. Right: In contact
mode the probe glides over the surface.

Contact mode is typically used for scanning hard samples and when a resolution of greater than
50 nanometers is required. The cantilevers used for contact mode may be constructed from
silicon or silicon nitride. Resonant frequencies of contact mode cantilevers are typically around
50 KHz and the force constants are below 1 N/m.

1.2.2 Tapping Mode

The constant force that the cantilever exerts on the sample in contact mode is often too large
when imaging biological samples. In these cases, it is more advantageous to image in the
dynamic mode, often also called tapping mode or intermittent contact mode. In this mode, the
cantilever is excited with an external piezo to vibrate close to its resonance frequency (see
Figure 8). When the oscillating cantilever approaches the surface, the amplitude of the
oscillation decreases, see Figure 8A. One can explain this by looking at the resonance behavior
of the cantilever far away from the surface (black curve in Figure 8B), and close to the surface
(red curve in Figure 8B). When the cantilever gets close to the surface, an additional restoring
force works on the cantilever (the tip sample interaction pushes the cantilever back), and this
can be seen as an increase in the spring constant, which manifests itself in a shift of the
cantilever resonance frequency to higher values (red curve). In tapping mode, the cantilever is
always excited at a fixed frequency that is chosen to be just below the free resonance frequency
fo. Far away from the surface, the cantilever will then oscillate with amplitude of Ay. When the
cantilever comes closer to the surface, the resonance curve shifts, but the cantilever is still
excited with frequency fy. The resulting amplitude is the A;. It is important to note, that the
cantilever still does touch the surface, but only at the bottom swing of the cantilever vibration.
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Figure 8: Amplitude dependence in tapping mode.

This drop in amplitude can be used as the feedback parameter for AFM imaging, just like the
cantilever deflection in contact mode (only that in tapping mode, decreasing the setpoint value
increases the force on the sample, while in contact mode, decreasing the setpoint decreases the
force on the sample). Using the change in amplitude as a feedback parameter is called
operating the AFM in amplitude modulation (AM) mode. One can also track the shift of the
resonance frequency of the cantilever when it approaches the surface. That is called frequency
modulated (FM) mode. AM mode (or tapping mode) is the most common way to operate the
AFM. Cantilever for tapping mode are stiffer than cantilever for contact mode to allow for a
higher resonance frequency. Typical values for k are 40N/m and f; 300-400kHz.

1.3 Piezo scanners

SPM scanners are made from piezoelectric material, which expands and contracts
proportionally to an applied voltage. Whether they elongate or contract depends upon the
polarity of the voltage applied.

ov +V -V
| | ——
= :‘_> L |
- - ‘\ Electrode

No applied voltage Extended Contracted

Figure 9: Piezoelectric effect. When a positive voltage is applied to the piezo, it extends, when a negative voltage is
applied it contracts.

The scanner is constructed by combining independently operated piezo electrodes for X, Y, &
Z into a single tube or flexure scanner, forming a scanner which can manipulate samples and
probes with extreme precision in 3 dimensions.

10
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Figure 10: Piezo tube scanner.

1.3.1 Raster scanning

The X-Y signal generators create a series of voltage ramps that drive the x and y piezolectric
ceramics in the AFM, as illustrated in Figure 10. The scan range is established by adjusting the
min and max voltage. The position of the scan is established by off setting the voltages to the
ceramic. Finally, the scan orientation is rotated by changing the phase between the signals.

1.3.2 Hysteresis

Because of differences in the material properties and dimensions of each piezoelectric element,
each scanner responds differently to an applied voltage. This response is conveniently
measured in terms of sensitivity, a ratio of piezo movement-to-piezo voltage, i.e., how far the
piezo extends or contracts per applied volt. Sensitivity is not a linear relationship with respect
to scan size.
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Figure 11: PZT materials have hysteresis. When a voltage ramp is placed on the ceramic, the motion is nonlinear: A)
due to the hysteresis, the piezo behaves differently when it expands than when it contracts. B) A triangular command
signal (left) results in a distorted output signal (right). C) Creep occurs when a voltage pulse on a PZT causes initial
motion followed by drift.

Piezo materials have inherent nonlinearities and hysteresis. The effect of nonlinearity and
hysteresis can be seen from the curves in Figure 11. As the piezo extends and retracts
throughout its full range, it moves less per applied volt at the beginning of the extension than

11
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near the end. The same is true when the piezo is retracting. This causes the forward and reverse
scan directions to behave differently and display hysteresis between the two scan directions.
Nonlinearity and hysteresis can cause feature distortion in SPM images if not properly
corrected (see Figure 12).
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Figure 12: 100um x 100um scans in the forward (trace) and reverse (retrace) directions of a two-dimensional 10um
pitch grating without linearity correction. Both scans are in the down direction. Notice the differences in the spacing,
size, and shape of the pits between the bottom and the top of each image. The effect of the hysteresis loop on each scan
direction is demonstrated.

1.3.3 Creep

Creep is the drift of the piezo displacement after a DC offset voltage is applied to the piezo, see
Figure 11C. This may occur with large changes in X & Y offsets, and when using the frame up
and frame down commands when the piezo travels over most of the scan area to restart the
scan. When a large offset is performed, the scanner stops scanning and a DC voltage is applied
to the scanner to move the requested offset distance. However, the scanner does not move the
full offset distance all at once. It initially moves the majority of the offset distance quickly, and
then slowly moves over the remainder. The scanning resumes after a majority of the offset
distance has been moved although the scanner is still slowly moving in the direction of the
offset. Creep is the result of this slow movement of the piezo over the remainder of the offset
distance once scanning has resumed. Creep appears in the image as an elongation and
stretching of features in the direction of the offset for a short period of time after the offset.

2 PRACTICAL WORK

2.1 Preparation of Samples

211 Collagen

Material

Rattails , scissors, petri dish, mica on a metal disc, tweezers

Method

Rattails are used as a source to extract collagen from. This structure which basically represents
an extension of the vertebral column contains a lot of collagen fibers which can easily be
isolated. The vertebral column basically comprises of a stack of bones with intervertebral discs
in between forming a canal wherein neurons run from the brain to a specified location in the
body. Different tendons comprising of a high fraction of collagen run along the vertebral
column to stabilize it and these will be isolated.

12
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First, the frozen tail needs to be thawed and 2 — 3 caudal vertebrae have to be cut off at the end
of the tail that faces the rat body with scissors or pliers. At the discus intervertebralis the
vertebral column can easily be cut as there is only soft connective tissue at these sites and no
bones present. This will expose bundles of collagen fibers running through the vertebrae. In the
next step a short part of the skin at the end of the tail needs to be removed. Therefore the skin is
cut with scissors and then simply stripped off in order to make the tendons accessible for
extraction. White bundles should now be visible which can be isolated by wrapping them
around scissors and then slowly pulling them out of the tail. Make sure to immediately transfer
the so isolated tendons into a petri dish containing some water in order to prevent them from
drying.
\ L A7) Tendon
( X)) ( \ \S'rr'uc‘rure

A\ L ‘ W Endotenon
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[ /A Primary
/ Z Y ' fiber bundle
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Figure 13: Chematic depiction of a tendon. For AFM imaging, we want to access the collagen fiber.

Now that the tendons are isolated the mica surface on top of which the collagen fibers will be
imaged needs to be prepared. Therefore a disc of mica is glued on top of a metal disc first
(already done for you by your TA). One of the characteristics of mica is a nearly perfect
crystal, that can be cleaved due to its hexagonal sheet-like arrangement of its atoms. By using a
piece of scotch-tape, one can cleave off the upper mica layers and get a very flat (atomically
flat) surface. This done the mica substrate is placed into the lid of the petri dish and some water
is added to the top. One bundle of the extracted tendons is placed across the mica disc such that
the ends of the tendon are in contact with the plastic material of the petri dish and by drying out
will be fixed to it easing the process of exposing the collagen fibers. This bundle is now opened
up thereby exposing a whole network of individual collagen fibers. With the help of two sharp
tweezers the tendon can be pulled apart so that the individual fibers will be spread across the
whole mica disc. This can be done under the light microscope where these small fibers will be
visible. In order to dry the sample the water on the mica disc can be sucked away carefully at
the brim with a paper towel and subsequently left for some time at room temperature.

21.2 E.coli

Material

Centrifuge, microtubes, pipette, fresh E.coli, mica

Method

Bacteria will be taken from an E.coli culture with an ampicillin resistance grown overnight in
Luria Broth medium supplemented with Ampicillin at 37°C in the shaker. 300 pl of bacteria
solution are transferred into a microtube. Another microtube with an equal volume of water
will be used as a counterweight in the microcentrifuge. The bacteria are pelleted at 13’000 rpm
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for 1 minute. After the supernatant is discarded the bacteria are resuspended in 300 pl Mili-Q
and washed again. After the second washing step the bacteria are resuspended in 1 ml of Mili-
Q. Depending on the turbidity of the solution between 20-100 ul will be evenly spread on the

freshly cleaved mica disc. The mica disc can be dried by a nitrogen flow to remove the water
layer on the sample.

2.2 Imaging

2.21 Setup: Loading and aligning the cantilever

The samples will be imaged with the Atomic Force Microscope Dimension FastScan from
Bruker. First it has to be made sure all the cables from the head are plugged in properly to the
platform and then the Nanoscope V, Stage Controller and HV Amplifier are turned on.
Subsequently the Nanoscope software can be started. The first window allows you to choose
the type of experiments you will be doing. In the Tapping mode select the experiment group
Tapping in air.

In the next window you are prompted to Load a probe, Focus Tip, Align Laser, Choose Tip
Location and Tune Cantilever.
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First thing to do is to load a probe.

1. Click the button Change Probe then remove the Z.scanner when the High Voltage
indicator on the head is off (hold with one hand the Z-scanner and press with the other
hand the button “Z-scanner” on the AFM). BE CAREFULL NOT TO DROP THE Z-
SCANNER! The probes used are silicon tips on a nitrite lever with different
characteristics depending on the type of experiment you want to perform. For tapping
mode imaging in air we use a Fast Scan-A Probe, having a typical resonance frequency
between 800 — 2000 kHz and a stiffness of 10-25 N/m.
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2. Put the Z-scanner back in place

3. Focus the camera on the tip for aligning the laser (software). The laser can quickly be
aligned by double clicking on the tip with the mouse courser in the camera image or
otherwise by directing the laser point with the arrows indicated in the window Align
Laser. Optimization of the laser position as well as the Aligning Detector can be done
automatically by clicking Optimize Laser Position or Autoalign Detector, respectively.
Then the tip location can be chosen if known and the cantilever has to be tuned.

2.2.2 Setup: Tuning cantilever resonance

Next we find the resonance frequency of the cantilever:

1. Click manual tune and adjust the properties settings such that the tune is done in the
range of the specified resonance frequency of the mounted probe.

2. Then focus the sweep width to the area of the peak and adjust the drive amplitude in
order to get an amplitude peak of about 10 nm.

3. Choose a drive frequency which is a bit lower than the peak resonance (green line)
and set the amplitude setpoint (pink line) to about 80% of the amplitude value at the
chosen frequency (intersection between green line and blue line) as indicated in the
picture.

4. These done, push zero phase button and exit.
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2.2.3 Navigate: find imaging position on sample

In the menu navigate the region of interest of the sample is positioned underneath the tip by
moving the stage with the arrows in the window Navigate to Scan Centerpoint. Then the
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camera is focused on the sample surface by moving the head down. Make sure to lower the
head slowly to avoid crashing into the surface and damaging the tip or the scanner. When the
surface is in focus the sample can be moved around to find a suitable location where you want
to image.
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2.2.4 Check Parameters

To start the imaging procedure it is important to scan a small area only at the beginning and
that your feedback gains are low ( < 1 ). Make sure the Z range value is set to maximum (ca
3.8um) as well as the amplitude range (1000mV) and Deflection Limit (25V). Choose the
number of samples per line and the number of lines per sample. Now you are ready to engage!
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2.2.5 Engage: approaching the sample

Fia Eeoimert Muvecops Ecan Cophre Stage Calbrale Tods Hob

e fapping
amplitude falls below the setpoint, the stepper motor stops and the AFM starts scanning.

2.2.6 Optimizing Imaging parameters: tuning feedback

There are a lot of parameters and settings that can be adjusted in order to get a good resolution
of the picture. The most important thing is to properly tune the amplitude setpoint and the
feedback gains.

1. Increase the amplitude setpoint to a value where the tip is not anymore tracking the
surface. This can be observed when the frace and retrace lines are not anymore
superimposed and appear as straight lines.

2. Lower the amplitude setpoint gently, just until the tip is tracking again and the trace and
retrace line overlap. Make sure that the AFM tracks everywhere. If the setpoint is not
low enough, you will see areas where the tip never touches the surface. This is called
“parachuting”.

3. Adjustment of the Integral and Proportional Gains will further improve the quality of
the picture. First: increase the integral gain value in small steps until “the feedback
loop starts to ring” which can be identified in the Amplitude window as an “increased
source of noise”. Then lower the integral gain again to a value where it does not ring
anymore. The same procedure can be done for the proportional gain.

4. Now, when the surface is being tracked well increase the scan size to several
micrometers to get an overview of your sample.
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2.3

1.

Images to collect:

Record images of collagen fibrils in tapping mode in air with the scan sizes of: 500nm,
lum, Sum, and 30um. Record the 30um and Sum images at a pixel resolution of
2048x512 and the smaller ones of 1024x1024. Make sure that you get areas that show
the periodic banding pattern of the collagen fibrils well, especially in the 500nm and
lum image. Try to have exactly one fibril in the middle of the image, without any other
ones going perpendicular to it. Of the 500nm or lum image record a second one with
the fast scan axis perpendicular to the collagen fibril. You will need this later in the
analysis section to accurately determine the periodicity of the D-banding.

For the E.coli record 3 images of scan size 30um at different locations at a resolution of
2048x512, make sure you have at least 50 different bacteria in total in your images.
Afterwards zoom in on one bacterium and take an image at a pixel resolution of
2048x1024. The single bacteria image will later be used to do a 3D representation while
the overview images will allow getting values for the average length and height of the
bacteria.
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3 AFMIMAGE PROCESSING AND ANALYSIS

All measurements and measurement techniques are prone to artifacts. In AFM imaging, these artifacts
are sometimes easy to spot and sometimes very difficult. Some artifacts can be easily avoided, if the
user knows what to look for and knows the source of the artifact. A few artifacts are unavoidable, but
knowing that they exist in an image helps to avoid misinterpreting them as genuine image features.
This means that recognizing image artifacts is very important for the AFM user.

Therefore, some image processing is usually necessary before viewing or analyzing any AFM image. All
processing is done with the aim of clarifying the data obtained during measurement. In other words,
the purpose is to make it easier to measure and observe the features that have been measured.

Because image processing operations can also introduce artifacts in the image, they
should only be used when necessary! Which processing operations will be used depends
highly on the image and the properties we want to measure.

For the processing of the AFM images we will use Gwyddion, which is free and open source software
for SPM (Scanning Probe Microscopy) data visualization and analysis. All information about this
software can be found at http://gwyddion.net

3.1 Gwyddion file handling

3.1.1  Openingfile:

Go to File->Open and then find the directory of the file you want to open. Once you click on the file,
all the images that the file contains will be shown on the right.

Once the file is opened, go to Meta->Show Data Browser to open/close desired images, i.e. images
within the file that you wish to process and analyze. The images that are checked will be opened. But
be aware that if you uncheck all of them — the opened file will close!
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n Open File
"
Places Name -~ Size Modified ~ | collagen120216.000
, | nanoscope. 3 ch
“\ Search I collagen 120216.000 120 MB Thursday
@ Recently Used " collagen 120216.001 120 MB Thursday B
[ Maja [ collagen 120216.002 120 MB Thursday k
[ Desktop [ collagen 120216.003 30MB Thursday
. Height [m]
& Local Disk (C:) | collagen 120216.004 30MB  Thursday 20481024 px
. Data (D) _ collagen 120216.005 30MB  Thursday 20.0x20.0 pm
& DVD RW Drive (E:) [ collagen 120216.006 75MB  Thursday R ——
 DVD Drive (H:) 7 collagen 120216.007 75MB  Thursday e SRS ;
7 collagen 120216.008 75MB  Thursday |= s B (7
. AN MR
D collagen 120216.009 38MB Thursday AmplitudeActual [m]
! collagen 120216.010 75MB  Thursday 2048x1024 px
7 collagen 120216.011 700KB Thursday 200x20.0 pm
[ collagen 120216.012 75MB  Thursday
H collagen 120216_2D_FFT.gwy 0 bytes  Friday -
Phase [deg]
2048x1024 px -
- B =]
File type: Automatically detected
-Qancel :,-m
| —— S )

Figure 14: Opening a file in Gwyddion

DR
i Y %ﬁ AmplitudeActual

[7] Phase

Figure 15: Opening images within the file in Gwyddion

3.1.2 Saving afile:

To save the file (containing all the images), go to File->Save as. Find the folder you wish to save your
file in. Then, at the bottom of the window chose the proper extension of the file .gwy. On the top give
the desired name to your file, but make sure to type it with the extension, e.g. name_of_the_file.gwy.
Then click Save. You can also save just single image, by choosing one of the image formats, but also
make sure to type the desired image name with the proper extension (e.g. name_of_the_file.png).

20



ADVANCED BIOENGINEERING METHODS LABORATORY )
Atomic Force Microscopy

. ECOLE POLYTECHNIQUE
Georg Fantner FEDERALE DE LAUSANNE

r — N
Save File — —— [EE=y =
Name: collagen 120216.gwy

Save in folder: collagen AFM Create Folder

Places Name ~ Size Modified -
\ Search collagen 120216.000 120 MB Thursday
@ Recently Used collagen 120216.001 120 MB Thursday .
5 Maja collagen 120216.002 120 MB Thursday
[ Desktop collagen 120216.003 30MB Thursday
& Local Disk (C:) collagen 120216.004 30MB  Thursday
~ Data (D) collagen 120216.005 30MB Thursday
# DVD RW Drive (E)) collagen 120216.006 75MB  Thursday
# DVD Drive (H:) collagen 120216.007 75MB  Thursday |= E
collagen 120216.008 75MB  Thursday
collagen 120216.009 38MB Thursday
collagen 120216.010 75MB  Thursday
collagen 120216.011 70.0KB Thursday
collagen 120216.012 75MB  Thursday
[ collagen 120216_2D_FFT.gwy 0 bytes Friday
S - HEBE

=) File type: Gwyddion native format (.gwy)
Automatic by extension

ASCI data matrix (.bd)

Assing AFM files (.afm)

Carmiddiam Cimnnla Cinld £ arfl

[m] »

Figure 16: Saving a file in Gwyddion

3.2 Image corrections

Various types of image levelling operations are usually the first processing operations carried out on
the AFM image data and often the only processing step used on AFM image data.

3.2.1 Line median matching

During imaging it can sometimes happen that cantilever change the level of interaction with sample or
some mechanical disturbance can cause shift in the laser beam deflection. This will cause the jumps in
the AFM height image on the slow scanning axis. That is why it is sometimes necessary to first do the
line by line height median matching.

[=) Datz Process

To do this in Gwyddion go to

Data Process -> Correct lines by matching height
median

This will do the height line median matching for
all horizontal lines of the AFM image.

On the Figure 1 you can observe that, while this operation did some successful leveling on the upper
part of the image, it introduced new leveling artifacts on the border areas of EPFL logo. So this
operation should not be used on the images where there is a horizontal sample with large height
difference with respect to the background. Misuse of this operation could also be explained on the
example of vertically and horizontally imaged collagen fiber, Figure 18.
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Before After
Figure 17: AFM image of the EPFL logo grating before and after he line by line height median subtraction operation

Collagen fiber, vertically imaged, before line Collagen fiber, vertically imaged, after line
median matching operation median matching operation ©

Collagen fiber, horizontally imaged, before line Collagen fiber, horizontally imaged, after line
median matching operation median matching operation ®

Figure 18: AFM images of vertically and horizontally imaged collagen fiber, before and after the line by line height
median matching operation
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In the case of horizontally imaged collagen fiber, we lost the height information of our
collagen sample by doing the line median matching operation!

In the case of the artifacts on the EPFL logo image, these can be better removed by using the
Tools->Level rows using intersections with given lines. With this operation we can actually select on
which part of the image we want to apply the line median matching operation. This is shown in the
images below.

(= Tools To do this in Gwyddion go to

%a I} 4& M Tools->Level rows using intersection with given
ﬁf & | 2 I,ég\ lines

BEN ' 2oy the line median subraction and clck

pa—y Apply.
Ld
B ¥ [N (= | -
e Q Notice that there is a thickness parameter. By
[ @' - setting it you can chose which amount of the
line neighboring pixels will be used in leveling.

EdEr e d Brrd BondBacd Brrd b d Bacd Brcd =t

)

6| \l|.|l‘ |q| |S| 1V| lE| |Z| |]|.u|”'""
=] [

(0.65 um, 9.95 um): 56.5 nm

Before After

Figure 19: AFM image of the EPFL logo grating before and after the line by line height median matching operation on
specific areas

3.2.2 1st order plane leveling

If the background in the image (such as the substrate on which the sample was deposited) has
considerable tilt in it, the change in height of the background will mask the changes in height
associated with the sample. This effect is shown in the image below.
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Unlevelled (raw) data 1st order levelled

Figure 20: AFM image before and after background tilt removal

This effect can be avoided either by using a global plane subtraction, or by using a 3 point
fitting (3 point plane subtraction).

3.2.3 Global plane subtraction

[=] Datz Process

HAIRR S

NEE

QN

2 R B I

In order to do the plane subtraction, in Gwyddion go to
Data process->Level data by mean plane subtraction

By clicking on it, Gwyddion will automatically calculate the
background plane and subtract it from the image.

height difference with respect to the background because it

:: This operation should not be applied if the sample has large
will not flatten the background tilt properly!

3.2.4 Three-pint fitting
This procedure is similar to plane subtraction, but is a rather more ‘manual’ and often more accurate
approach. In this method, the AFM user identifies three points on the image to define the plane to

subtract.
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M In order to do the three-point fitting, in Gwyddion go to

ISO Tools -> Level data by fitting the plane through a three points
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Set Averaging radius of the points to 10 px.
| Now select 3 points in image background, as
n x [um] y [um] Value [um] far away from each other as possible and
1 2473 1514 ‘ click Apply. Image should now be leveled.
2 0948 19.248 Click Clear to remove the points and close
3 19,597 1.100 Three point level window.

6

Averaging radius:

["] Instant apply
["] Set plane to zero

Clear ||

Before After

Figure 21: AFM image before and after three-points plane fitting

3.2.5 Scar correction

Scars (or stripes, strokes) are parts of the image that are corrupted by a very common scanning error:
local fault of the closed loop. For instance, if a cantilever suddenly encounters a very high topography
(e.g. like dirt present on the sample), it will take a while for the closed loop to return again to proper

following of the sample topography. Line defects are usually parallel to the fast scanning axis in the
image.

[=] Data Process
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To remove scars in Gwyddion go to Data Process->Correct horizontal scars (strokes). This function will
automatically find and remove these scars, using neighboring lines to ‘fill-in’ the gaps.

Figure 22: AFM image before and after scar correction

3.2.6 Higher order leveling
A common problem in AFM images is a scanner bow. It occurs mainly in instruments that use tube

scanners, and is caused by a swinging motion of the free end of the scanner. This leads to introduction
of a curve in the image plane, as shown in the image below.

0.0 um 10.0 um

Fixed microscope structure

"/\/\/\/"l v \Jr\/\"/\l\,\A

0nm £
— , 0.0 um 10.0 um

Figure 23:. Effect of scanner bow on the AFM image

In order to remove this curve and similar image distortions that can arise from AFM system, we will
use higher order polynomial two-dimensional curve fitting. This processing works well in the case
where the background (on which the sample is deposited) is flat, and does not include any curvature.
Typical examples of this case would include nanoparticles on a wafer, microorganisms on glass slides,
or individual molecules on mica.
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Note that if AFM microscope uses a flexure scanner instead of a tube scanner, scanner bow artifact
will not be an issue.

Before doing this 2D curve fitting and removal operation, first we would need to select our sample to
exclude it from the two-dimensional curve fitting, because we want to perform the 2D curve fitting
only on the sample background.

SRl To do this in Gwyddion go to

Y\ﬂ ﬁ 8 H E Data Process -> Mark grains by threshold
- B EE
EELE

e e |

Threshold by
Height:

Check Threshold by: Height and change
34;,2; “ | the percentage of the Height parameter
[ Slope 0 [1000 [ % until the entire sample is selected, then
[7] Curvature:  |1000 5 % click OK

Options
[7] Invert height

Moskcolor: 18

Instant updates

pdate | [ Beset | [ canca |[ ok ]

Now we will do the higher order polynomial two-dimensional curve fitting.

[=] Data Process

= 8
AEE
<Y @Y [
DIV

To do this in Gwyddion go to
Data Process -> Remove polynomial background

[z '."l i
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81 Remove Polynomial Backaround S BT Set value for Horizontal polynom degree and

. - - - Vertical polynom degree parameters (2-3).

Leveled data Background
In the Masking Mode part check the Exclude

@ Independent degrees

Tl poE e e b masked region option. This will exclude our
Vertical polynom degree: 0 2 b previously selected sample from the 2D curve
Same degrees f|tt|ng
Limited total degree .

- Click OK.
Maximum polynom degree: i} 3
[T] Extract background
Masking Mode
@ Exclude masked region
(© Include only masked region

*) Use entire image (ignore mask)
Reset ] [ Cancel ] [ oK ]
1st order levelled 2nd order levelled
f ( ‘ ‘
|

Image 8. AFM image before and after higher order 2D curve leveling

After this is done, to deselect the sample selection, again go to Data Process -> Mark grains by
threshold, uncheck the Threshold by: Height and click OK.

3.3 Image representation

3.3.1 Color Range

Gwyddion automatically sets the color range of the image to include all the topography in the image. If
there are regions with high topography present in the image (e.g. dirt), the regions with the low height
will be ‘masked’ by it and distinguishing the details in low topography regions will be hard. That is why
it is sometimes needed to adjust the color range to the height range of interest.
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To do this in Gwyddion go to
M Tools -> Stretch color range to part of data

© 00|\ ColorRange

& | e | O default Window will open. Chose the second tab:

L On the presented histogram select the desired range by
Range dragging the mouse or by typing in Minimum and Maximum
Minimum |-2313.798 <[ nm range values.

Maximum |-2310.481 > nm
Full

Minimum -2333.92 nm
Maximum -2291.59 nm
Oorigin

X 0.000 um [0 [%| px
Y 0.000 pm |0_E! px
Size

Width 2.000 um |1024 %l px
Height 2.000 um |512 ll px

Hide |

/

Figure 24: AFM image before and after the change of the color range
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3.3.2 Color palettes

. _ ERRERIBWL
The color palette used to display an AFM image B Glend?
can be selected to make the image seem more B  Caribbean
visually compelling. In some cases, selecting a B Cod
specialized color pallet can help with visualizing BB W DFit
certain aspects of an image. In Gwyddion you can E  Gold
change the color palette by right clicking with a T Gray
mouse on the color bar located on the right side B Green-Violet
of an AFM image. Gwyddion.net
B | | Lines
| Olive
R Rainbow?2
H  Red
N sy
I T Spectral
E Spring
[ . Warm
More

3.3.3 3D Data representation

AFM height data is inherently three dimensional (3D). However, the standard method of rendering
AFM data displays a two-dimensional (2D) image, using a color scale to represent height information.
This is not a normal way for humans to see shapes, and can make interpretation difficult. In particular,
for viewers unused to AFM data, it can be difficult to determine which features are higher than others,
etc. One way to overcome this is to render the height information as a pseudo-three-dimensional
image. The ability to display images that show what we want is vital, in order to make use of AFM
data.

B View To present AFM image in 3D, in Gwyddion go to

@ B ﬁ View->Display a 3D view of data

This will present AFM image in 3D. On the right,
there is a menu to process 3D image.

Use this button to enter advanced menu
with possibilities such as choosing a color
palette, choosing whether to show labels
and axis, choosing type of lighting etc.

D¢ FD2)|
2

-0.52 pym

If you selected the Lighting type of
image presentation in advanced menu,
use this button to change the spot of the
light source.

0.61 ym 0 Use this button to rotate 3D AFM image.
el

Use this button to save 3D image.

B
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3.4 Data analysis

3.4.1 Extracting profiles

Many times it is necessary to extract line profiles from the image in order to examine certain sample
characteristics. Since it is usually difficult to measure dimensions directly from AFM images, line
profiles are usually extracted in order to measure dimensions from the AFM images. Gwyddion allows
the user to arbitrarily define lines to be extracted, and these can be at any angle.

. To do this in Gwyddion go to
R 25|
Data Process -> Extract profiles
NS RR
' Clicking once on this button, external window will open

04z
Ra M
E N ﬁ to show line profiles.

BN ¥ [ =

Draw lines using mouse. If SHIFT button is
held while doing this, lines will be drawn
only under certain angles (use this to easily
draw horizontal and vertical lines). You can
draw more than one line.

In the external window you will get line
profiles.

You can use mouse to draw several profiles
in the image and they can be further moved
and adjusted. The window includes a live

%'w profile graph preview.

-20
- Options 20 Different ‘thickness’ can be set for profile
Thickness: B} 1 e lines. This means that more neighboring
gi‘p’z;gﬁm BE I pixel data perpendicular to profile direction
Interpolaion ype: 0 - > will be used for evaluation of one profile

g |[ mee |[ mey || point of the profile line. This can be very
useful for suppression of the image noise,
when measuring objects in the image.

Click Clear button if you want to clear all selected line profiles. Click on the one of the profiles and
press Delete button to delete that specific profile line. Click Apply button to continue further analysis
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of the line profiles. New window will open containing several options:

Use this marker button to measure distances in a graph, both horizontally and vertically.
You can place many markers on a graph.

Use these buttons to zoom in on the desired area of the graph and to zoom out to full
graph curve.
@E Use these buttons to logarithm x and y axes.

3.4.2 2D FFT Analysis

In AFM image processing and analysis, a two-dimensional Fourier transform is an operation that
converts the AFM image from the spatial domain, into the frequency, or more correctly, the
wavelength domain. This is carried out by a mathematical operation known as a fast Fourier
transform, so is sometimes also known as FFT analysis.

Figure 25: Several examples of 2D FFT of simple cosine-like images

When transformed into Fourier space, the image will show features in terms of wavelength (or
frequency). This is particularly useful to identify any repeating patterns in the image. For instance, 2D
FFT can be used to calculate period of atomic lattice parameters, depth of corrugations on the
collagen fibers etc. The Fourier transform can also be used to identify the frequency of noise in an
image and to remove it.
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In general, rotation of the image
results in equivalent rotation of its FFT.

This is shown on the images on the left,
where the FFT of a simple cosine and
also the FFT of a rotated version of the
same function is presented.

To do the 2D FFT in Gwyddion first open an image you want to apply it to. You might want to do the

2D FFT only on one part of the image. To do this go to Tools->Crop data @ and select the desired
image area. 2D FFT image will be much clearer if it is applied to the squared image (equal number of
pixels on horizontal and vertical axis). So, to do this first go to Data Process->Basic Operations-
>Square Samples. Then do the 2D FFT by going to Data Process->Integral Transforms->2D FFT.

‘@ o ) (-

Windowing type: |Hann v

|

Output type: IModqus v

|

7| Subtract mean value beforehand

| Reset || Cance || oK

= View

[CIFcRcys

External

window will be opened to set FFT

parameters. You can leave default parameters and

click OK.

You can click on the View->Zoom in button to zoom
into 2D FFT image details.
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Use on this image the Extract profile tool (which has
already been explained), to determine spatial
frequency and period of the measured pattern (e.g.
period of the collagen corrugations).

3.4.3 Tip diameter estimation

Typically, cantilevers with blunt tips will lead to images with features larger than expected and with a
flattened profile, due to the effect shown on the image below. Note that holes in a flat surface will
show the opposite effect, appearing smaller with blunt probes than with sharp ones.

Blunt tip Sharp tip

\ e e
v\

Figure 26: Illustration of the impact of the shape of a tip on the AFM image

In many cases this effect can be negligible, e.g. if the cantilever tip is much smaller then the features
of the image being measured. However, sometimes it may significantly alter the apparent size of the
features, and then it can noticeably change their appearance. Therefore, it is useful to know how to
estimate diameter of the cantilever tip to properly evaluate the accuracy of measured data.

This estimation is usually done by first imaging a sample which has sharp and high edges in the
topography (e.g. special “Tipcheck AFM Tip Imaging Sample”). Then, estimation of the tip topography
can be done using the obtained image of the Tipcheck sample. This estimation is integrated in the
most of the software for SPM image processing.

In Gwyddion, to do this estimation, first open the AFM image of the Tipcheck sample. Then go to Data
Process->Tip->Blind Estimation.
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The window shown on the left will
open. From the measured AFM
image of the Tipcheck sample

Related data: |EHeight v

| roughly estimate the width and

Estimated Tip Size

the height of the tip (look at

Width: 0 59 = px diameter of the grains in the
Height: 0 59 2 px sample image). Enter these
[v] same resolution estimates in the Width and the
Noise suppression threshold: 10000 |- Height fields.
Use boundaries
Click on the button Run Partial.
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topography of the tip and present
it in the small window within. Click
OK button.

The image containing tip topography will then
be opened. Use on this image the Extract
profile tool (which has already been explained),
to determine the diameter of the tip. Draw two
perpendicular profile lines through the highest
point of the tip (they don’t need to be
horizontal and vertical ones). Then in Profiles
window click Apply.

Click on the marker tool in new Profiles window (shown below) and find out the radius of the tip at 5
nm and 10 nm distance from the tip’s highest point. Cantilever manufacturers typically cite this value

as the tip radius.
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Tipcheck sample AFM images obtained with blunt and sharp tip cantilever are presented below, along
with the tip topography estimates.

Blunt tip: Image of the Tipcheck sample Blunt tip: Tip topography estimation

2012-02-1 e S

(125 nm, 93 nm): 34.3 nm

Sharp tip: Image of the Tipcheck sample Sharp tip: Tip topography estimation
Figure 27: Sharp and blunt tip, AFM image comparison and tip topography estimation

Once tip topography is estimated, this can be used to reconstruct the more accurate image of the
sample. In Gwyddion, this is done by going to Data Process->Tip->Surface Reconstruction. However,
this usually successfully works only in the case when sharper tips are used for imaging.

4 ANALYSIS OF THE DATA OBTAINED IN THE LAB MODULE

4.1 Steps equal for all images

* Open AFM file in Gwyddion

* Open the channel (type of image: topography, amplitude, phase) you want to process.

* Rescale the image to have equal number of pixels in both axes: Data Process/Basic
Operations/Square Samples

* Adjust the color range: Stretch color range to part of data, so that you have good
contrast

* Pick a color pallet you like (by right-clicking on the Z-scale)
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* Perform background subtraction, line-by-line flattening and scar correction if necessary.
What is the correct order to do these operations? Check if your color range is still
correct, readjust if necessary.

4.2 Analyzing AFM image of collagen fibers

*  Process the collagen fiber AFM image to remove existing image artifacts.

* Determine the average depth and the period of the collagen fiber corrugations using Extract
profile tool. Take several line profiles (10-20). For each line, note the length of the line and the
number of periods. From this data, calculate the periodicity of the D-bandin. Estimate an
error.

* Onyour high resolution image. Measure the depth of the corrugation. Calculate average and
perform the appropriate error analysis.

* Determine the corrugation period of the collagen fiber again, by using 2D FFT analysis:

o Crop a high resolution area from your AFM image where you have as many D-bands as
possible.

Square the samples

Apply 2D FFT analysis

Extract the proper profile and measure the D-banding period from the FFT

Compare the values obtained by FFT with those obtained earlier.

O O O O

4.3 Analyzing AFM image of E. Coli bacteria

*  Process the E. Coli bacteria AFM image to remove any image artifacts. Make sure that you
flatten the image properly.

*  From the high-resolution image, make a 3D plot. Use the phase channel for color overlay.
Adjust the size, rotation and lighting to get a really good looking 3D image of your bacterium.

* From the overview images, extract the lengths and heights of at least 50 bacteria. Calculate
the average length and the average height. Estimate/calculate the error of your measurement.
Should you report the standard error or the standard deviation, and why?

4.4 Cantilever tip estimation

You will be given two images of a TipCheck grating, imaged once with a sharp tip and once with a blunt
tip.

* Perform the necessary image processing to remove artifacts.

* Perform a blind tip reconstruction for each image.

* Measure the cone radius (tip radius) for each image at 5nm and 10 nm from the tip apex. If
the tip is not rotationally symmetric, calculate the maximum and minimum radius.
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